The matrix below is to demonstrate which Joomla versions are supported by our extensions. Please consult this table before attempting to install our software on your site.

You are strongly advised to use the latest version of your Joomla! CMS at any time.

Please note that only the latest released stable version of each of our software is supported at any given time.